要チェック*Gulpエラー:Task function must be specified

Gulp

こんにちはエラー

Task function must be specified

Gulpを新たにインストールして、以前のgulpfile.jsを複製して使用したら、エラーが出て使えませんでした・・・・。

Task function must be specified

 

どうやら、Gulpのバージョンアップによるエラーのようです。

Gulp4では、gulpfile.jsの書き方に変更があるようなので、要チェック。

 

対応

gulp.taskgulp.watchに変更あり。

gulp.task

変更前 ~v3

gulp.task('default', ['task1', 'task2'], function(){
    // ...
});

変更後 v4

gulp.task('default', gulp.series( gulp.parallel('task1', 'task2'), function(){
    // ...
}));

 

gulp.watch

変更前 ~v3

gulp.task('sass', function () {
gulp.watch('./sass/**/*.scss', ['sass-min']);
});

変更後 v4

gulp.task('sass', function () {
    gulp.watch('./sass/**/*.scss', gulp.task('sass-min'));
});

 

まとめ

Gulp3 から Gulp4 にアップデートされた際に、書き方の変更がいくつかありました。インストールしたgulpのバージョンを確認し、バージョンに合わせた書き方をすれば、問題なく動作します。

エラーの原因がなかなか見つからず苦労しましたが、公式サイトには変更点が掲載されているので、ここを見れば確実でしたね・・・・!

参考サイト

gulp v4.0.0がプレリリース! 移行方法と変更点まとめ
2018年1月1日にプレリリースされたgulp v4.0.0。その移行方法と主な変更点をまとめました。

バージョンアップの変更点

https://github.com/gulpjs/gulp/blob/4.0/CHANGELOG.md

コメント

  1. […] 要チェック*Gulpエラー:Task function must be specified […]